USB mouse not recognized

Area for discussing ST(E) clones

Moderators: Mug UK, Zorro 2, Greenious, spiny, Moderator Team

sblendorio
Atari User
Atari User
Posts: 41
Joined: Wed Jun 08, 2016 1:08 pm

USB mouse not recognized

Postby sblendorio » Sun Feb 12, 2017 6:19 pm

Hi, I have a nice USB mouse which is not recognized my MinimigMist. What kind of information can I report to try understanding why?
Those are device-related USB info I got from Windows... Hope it could help finding infos...

Schermata 2017-02-12 alle 19.13.54.png
You do not have the required permissions to view the files attached to this post.

sblendorio
Atari User
Atari User
Posts: 41
Joined: Wed Jun 08, 2016 1:08 pm

Re: USB mouse not recognized

Postby sblendorio » Tue Feb 14, 2017 11:16 am

I got the following output from USB debug: I started AtariST with no mouse connected, then I turned on Debug on USB, then I connected, then disconnected the mouse

Code: Select all

key 0x28 break: 0x1C
key 0x29 make: 0x1
key 0x29 break: 0x1
key 0x29 make: 0x1
key 0x29 break: 0x1
OSD is now invisible
status change on port 1, 0x10100
Status of port 1:
 powered
Changes on port 1:
 connected
 port 1 disconnect!
usb_release_device(parent=1, port=1
status change on port 1, 0x10301
Status of port 1:
 connected
 powered
 low speed
Changes on port 1:
 connected
 dev 1: port 1 connect!
resetting port 1
status change on port 1, 0x100303
Status of port 1:
 connected
 enabled
 powered
 low speed
Changes on port 1:
 reset
 port 1 reset complete!
usb_configure(parent=1 port=1 lowspeed=1)
using free entry at 2
Setting addr 3
usb_set_addr(new=3)
failed to assign address
status change on port 1, 0x10100
Status of port 1:
 powered
Changes on port 1:
 connected
 port 1 disconnect!
usb_release_device(parent=1, port=1

Sorgelig
Captain Atari
Captain Atari
Posts: 457
Joined: Mon Dec 14, 2015 10:51 am
Location: Russia/Taiwan

Re: USB mouse not recognized

Postby Sorgelig » Tue Feb 14, 2017 12:26 pm

USB stack on MiST is pretty simple and limited due to MCU firmware size limit. If mouse doesn't work then i'm afraid it won't be fixed. Find another mouse. Simpler mouse has more chance to be recognized. Anyway, only 2 buttons will be supported on any mouse.

hubersn
Atariator
Atariator
Posts: 18
Joined: Fri Sep 11, 2015 8:10 pm

Re: USB mouse not recognized

Postby hubersn » Tue Feb 14, 2017 3:38 pm

Sorgelig wrote:USB stack on MiST is pretty simple and limited due to MCU firmware size limit. If mouse doesn't work then i'm afraid it won't be fixed. Find another mouse. Simpler mouse has more chance to be recognized. Anyway, only 2 buttons will be supported on any mouse.


Really? 3 Button mouse works nicely on Archimedes Core with RISC OS.

Have fun
hubersn

User avatar
Newsdee
Atari Super Hero
Atari Super Hero
Posts: 854
Joined: Fri Sep 19, 2014 8:40 am

Re: USB mouse not recognized

Postby Newsdee » Tue Feb 14, 2017 4:59 pm

there is a mist.ini setting to enable "boot mode" for mice, try turning it on and see if it helps (I forgot the name but its in the source code of the fw)


Social Media

     

Return to “ST(E) Clones (Suska / MiST)”

Who is online

Users browsing this forum: No registered users and 6 guests