Problems using Lothark USB floppy drive emulator Rev. D HxC as external FDD

Everything related to using the HxC Floppy Emulator hardware on your Atari.

Moderators: mr.vince, DrCoolZic, Moderator Team

Boojakascha
Atarian
Atarian
Posts: 4
Joined: Sun May 14, 2017 6:38 am

Problems using Lothark USB floppy drive emulator Rev. D HxC as external FDD

Postby Boojakascha » Thu May 18, 2017 3:24 pm

Hello

I am using an Atari STE 520 with a HxC device called the "USB floppy drive emulator" in revision D made by Lotharek. This is the version which lacks jumper switches, but lets you select the device ID in software. Using this device as a internal floppy drive works acceptable. However I run into problems when I try to use it as an external FDD with a cable made by this guide:
viewtopic.php?t=26656
Sadly the Wiki entry which is mentioned in this guide is broken. All internal jumpers inside my STE are on their default (http://info-coach.fr.../interfaces.php) so pin 5 of the 14 pin connector would try to reach a FDD with ID 1 (rather than 0).

The problem is that it won't work for me... The control LED of the HxC device for floppy access just lights up if I set the HxC to DS2 (all normal) or DS1 (with twisted cable). With those configuration I can for example open the floppy folder of "orbital destroyer". The internal FDD does sounds when doing so. If I then start the game the internal FDD continues to make sound, but the external one isn't used.

The problem is the same if I cut the cable of (Atari STE-) pin 5 having it floating (Atari STE pin 6 still connected). However cutting 6 while having 5 still connected doesn't work.

Does someone of you operate a Atari STE 520 with a Lotharek USB floppy drive emulator as external FDD? Is this possible, or is there a funky bug? Has anybody an idea what I am doing wrong?

With kind regards
Ben

Social Media

     

Return to “HxC Floppy Emulator”

Who is online

Users browsing this forum: No registered users and 2 guests